OFTDeps 2019.0b->.0c (nedostatky a jiné postřehy)

Zdravím všechny, kteří si něco myslí o OFTDeps. Vzhledem k tomu, že Qt-Creator využívá k zpracování nekompilovaného zdrojového kódu libclang, vyvstal problém při jeho kompilaci, jelikož vyžaduje verzi 6.0.0 a v mnou zkompilované verzi 5.0.2 chybí !jedna! funkce, kterou se mi očividně nepodařilo mým boilerplate kódem funkčně nahradit.

Také kompilátor DSP Faust má nedostatek, jelikož jsem zapomněl povolit CPP backend. Tu úplně nejdůležitější část. 🙁

Mám dvě možnosti – provedu celý build znovu (pro jistotu všechny knihovny), nebo nahradím komponenty. -> Nahrazení LLVM a Clang by mohlo způsobit neočekávané nedostatky v rozhraní tříd. Zkompilovat znovu Faust s povoleným CPP je jen otázkou několika kliknutí. Takže 0c, nebo 0b2?

Samozřejmé je, že bych se měl pokusit pomrvit původní build méně, než-li je. Zazálohovat a prostě to zkusit. Takže nejprve 0b2, teprvé poté 0c.

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *

*

code